Sunday October 29, 2006

You must use Internet Explorer to live in Miami-Dade

'This site is best viewed with Internet Explorer' error message

Excellent work, guys, really. This is the page from which I got there, by clicking the “Find a park near you” link. Three observations here:

Overall, my impression is that miamidade.gov is a very information-rich site, but with lots of baffling gaps. Check out how the parks listed on pages like this don’t link to the parks’ pages. C’mon, guys; you can do better. Update: Dugg.

Tags: ,

comments powered by Disqus
  1. R.    Sun Oct 29, 03:29 PM #  

    if you think about it, around 90% of browsers used are IE, so it does kind of make sense.

    that said, I’m not sure why anyone would use IE over firefox… other than for viewing non-firefox compatible webpages.



  2. B.A.C    Sun Oct 29, 06:31 PM #  

    I can’t even remember the last time I used IE.



  3. Miami Transit Man    Mon Oct 30, 12:50 AM #  

    When You need a microsoft update…



  4. Jonathan    Mon Oct 30, 09:38 AM #  

    The Miami-Dade website is indeed lame. For it and similar dysfunctional sites I keep the latest version of IE, with lowest-security default settings enabled, on my computer. But not even an upgrade to multi-browser standards would fix the poor design here. Have you tried navigating via the menus? There are actually pages that you cannot reach. I found this out when I tried to pay a bill by going to the pertinent department’s home page. I couldn’t find the payment page. I succeeded only by manually entering the URL from the back of the billing envelope. A city government site that actually discourages revenue collection — amazing. The whole M-D site has a slapped-together feel to it.

    BTW, for great entertainment visit the code enforcement pages and search for “chicken busters.”



  5. kingofrance    Mon Oct 30, 10:03 AM #  

    My favorite is the link to complaints/suggestions on the Transit page:

    http://www.miamidade.gov/transit/complaint.asp



  6. Christian Calzadillas    Mon Oct 30, 10:08 AM #  

    The more awesome part is that I got that same error page even though I was using ie7!



  7. madeindade    Tue Oct 31, 09:42 AM #  

    I use emaps all the time with Firefox and it works fine… but in general the whole site is a poorly designed mess

    http://gisims2.miamidade.gov/emaps